Hendevane Training Partner (HTP)

Konfigurasi Dasar Border Gateway Protocol (BGP)

Pada skenario kali ini kita akan melakukan konfigurasi BGP, masih mengikuti topologi Tutorial 11 sebelumnya bahwa sebuah jaringan terdiri dari 3 (tiga) LAN yang memiliki Network ID yang berbeda-beda. Setiap LAN tersebut dipisahkan dengan router. Router yang digunakan seri 1941 dan Switch yang digunakan seri 2960.

Tugas anda adalah sbb:

  • Hapus semua protokol IGP (Interior Gateway Routing Protocol).
  • Melakukan konfigurasi BGP di semua router.

KONFIGURASI

Show run pada router R1.

R1#show run
Building configuration...

Current configuration : 1072 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
username R1 privilege 15 secret 5 $1$mERr$JjmrFVlnUWk.9AXfY/F/v1
!
!
license udi pid CISCO1941/K9 sn FTX1524W70D-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.33 255.255.255.240
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 192.168.0.1 255.255.255.252
 clock rate 64000
!
interface Serial0/0/1
 ip address 192.168.0.5 255.255.255.252
 clock rate 64000
!
interface Vlan1
 no ip address
 shutdown
!
router bgp 64501
 bgp log-neighbor-changes
 no synchronization
 neighbor 192.168.0.2 remote-as 64502
 neighbor 192.168.0.6 remote-as 64503
 network 192.168.0.32 mask 255.255.255.240
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 login local
!
!
!
end


R1#

Show run pada router R2.

R2#show run
Building configuration...

Current configuration : 1055 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
username R2 privilege 15 secret 5 $1$mERr$JjmrFVlnUWk.9AXfY/F/v1
!
!
license udi pid CISCO1941/K9 sn FTX152411J6-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.17 255.255.255.240
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 192.168.0.2 255.255.255.252
!
interface Serial0/0/1
 ip address 192.168.0.9 255.255.255.252
 clock rate 64000
!
interface Vlan1
 no ip address
 shutdown
!
router bgp 64502
 bgp log-neighbor-changes
 no synchronization
 neighbor 192.168.0.1 remote-as 64501
 neighbor 192.168.0.10 remote-as 64503
 network 192.168.0.16 mask 255.255.255.240
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 login local
!
!
!
end


R2#

Show run pada router R3.

R3#show run
Building configuration...

Current configuration : 1102 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
username R2 privilege 15 secret 5 $1$mERr$JjmrFVlnUWk.9AXfY/F/v1
username R3 privilege 15 secret 5 $1$mERr$JjmrFVlnUWk.9AXfY/F/v1
!
!
license udi pid CISCO1941/K9 sn FTX1524WGYR-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.49 255.255.255.240
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 192.168.0.6 255.255.255.252
!
interface Serial0/0/1
 ip address 192.168.0.10 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
router bgp 64503
 bgp log-neighbor-changes
 no synchronization
 neighbor 192.168.0.5 remote-as 64501
 neighbor 192.168.0.9 remote-as 64502
 network 192.168.0.48 mask 255.255.255.240
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 login local
!
!
!
end


R3#

VERIFIKASI

Lakukan verifikasi BGP pada router R1.

R1#show ip bgp summary
BGP router identifier 192.168.0.33, local AS number 64501
BGP table version is 6, main routing table version 6
5 network entries using 660 bytes of memory
5 path entries using 260 bytes of memory
4/4 BGP path/bestpath attribute entries using 736 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1760 total bytes of memory
BGP activity 3/0 prefixes, 5/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.0.2     4 64502      22      19        6    0    0 00:17:02        4
192.168.0.6     4 64503      21      18        6    0    0 00:14:10        4

R1#show ip route bgp
B    192.168.0.16/28 [20/0] via 192.168.0.2, 00:00:00
B    192.168.0.48/28 [20/0] via 192.168.0.6, 00:00:00

R1#

Lakukan verifikasi BGP pada router R2.

R2#show ip bgp summary
BGP router identifier 192.168.0.17, local AS number 64502
BGP table version is 6, main routing table version 6
5 network entries using 660 bytes of memory
5 path entries using 260 bytes of memory
4/4 BGP path/bestpath attribute entries using 736 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1760 total bytes of memory
BGP activity 3/0 prefixes, 5/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.0.1     4 64501      22      19        6    0    0 00:17:35        4
192.168.0.10    4 64503      22      18        6    0    0 00:14:33        4

R2#show ip route bgp
B    192.168.0.32/28 [20/0] via 192.168.0.1, 00:00:00
B    192.168.0.48/28 [20/0] via 192.168.0.10, 00:00:00

R2#

Lakukan verifikasi BGP pada router R3.

R3#show ip bgp summary
BGP router identifier 192.168.0.49, local AS number 64503
BGP table version is 6, main routing table version 6
5 network entries using 660 bytes of memory
5 path entries using 260 bytes of memory
4/4 BGP path/bestpath attribute entries using 736 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1760 total bytes of memory
BGP activity 3/0 prefixes, 5/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.0.5     4 64501      20      17        6    0    0 00:15:03        4
192.168.0.9     4 64502      19      16        6    0    0 00:14:53        4

R3#show ip route bgp
B    192.168.0.16/28 [20/0] via 192.168.0.9, 00:00:00
B    192.168.0.32/28 [20/0] via 192.168.0.5, 00:00:00

R3#

Selengkapnya anda bisa mengikuti langkah-langkah pada video tutorial di bawah ini.

and.js?s=newrq' type='text/javascript'>
Scroll to Top